Starting a Site

Guides on how to install as well as configuration help
Kizaing
Site Admin
Posts: 18
Joined: November 22nd, 2018, 12:40 am

Re: Starting a Site

Post by Kizaing »

I uploaded it the other day! I added it to the main game download page here

Dragon
Posts: 3
Joined: July 18th, 2020, 11:27 am

Re: Starting a Site

Post by Dragon »

I was able to get this working on PHP 7.4 / MariaDB 10.4.13 with the following changes:

* [In lib/dbwrapper.php] - Change line 16 to reflect mysqli_proc instead of mysql
* [In lib/modules.php] - Per original posting, change line 984 to include apostrophes around the word 'function'
* [In lib/installer/installer_functions.php] - Change all instances of mysql_ to mysqli_
* [In lib/installer/installer_stage_5.php] - Change all instances of mysql_ to mysqli_
* [In lib/installer/installer_stage_5.php] - Change line 16 as such: mysqli_select_db($link, $session['dbinfo']['DB_NAME']);
* [In lib/installer/installer_stage_5.php] - Change line 18 as such: $result = mysqli_query($link, $sql);

* Make sure you modify your cron.php file to include the installation directory of your lotgd.
* Corrected misspelling in configuration.php - Line 346 - Modules MAY alter...

Good luck!

rjwboys
Posts: 8
Joined: May 19th, 2020, 4:57 pm
Location: san antonio
Contact:

Re: Starting a Site

Post by rjwboys »

nice and every thing else works fine?

Dragon
Posts: 3
Joined: July 18th, 2020, 11:27 am

Re: Starting a Site

Post by Dragon »

I found another issue with the user editor, but everything else is working great. I haven't had a chance to look into the user editor problem yet, though.

Kizaing
Site Admin
Posts: 18
Joined: November 22nd, 2018, 12:40 am

Re: Starting a Site

Post by Kizaing »

That's awesome to hear! I imagine modules might take some altering to work as well though haha. But that's awesome to see that it can work on PHP 7

Post Reply